Downloads

This page contains downloads intended for clinical use. If you are a patient looking to view your scans, please see our VueMe app.

Some of these files are encypted with a password. To open and install them a password will be required.

Click here to get a password to use files after downloading.

Java 6 is required for Mac versions of MIM 6.4 or earlier.
Java 8 is required for Mac versions of MIM 6.5 or later.

For our Korean customers please click here to download MIM 6 software.